Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - ESB - Alto consumo de memória e CPU


Tempo aproximado para leitura: 00:01:00 min

Ocorrência

Consumo excessivo de memória e CPU pelo Java do serviço do TOTVS ESB.

Ambiente
TOTVS ESB - Servidor - Todas as versões


Causa
O montante de memória em megabytes que a JVM deve alocar não é suficiente.

Solução
Alocar mais memória para o TOTVS ESB pelo campo Maximum Memory.

01. Entrar no TOTVS Developer Studio.

totvs_developer_studio.png

 

02. Entrar no TOTVS ESB servers e escolher o ESB desejado.

esb_server.png

 

03. Na aba System Properties, selecionar as opções de Memory.

system.png

 

04. Configurar o uso de memória do TOTVS ESB.

Campo Descrição
Maximum Memory (MB) Tamanho máximo em megabytes do pool de alocação de memória.
Initial Memory (MB) Tamanho inicial em megabytes do pool de alocação de memória.
Allocation Memory by Thread (MB) Tamanho em kilobytes de alocação de memória por thread.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _