Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - WCM - Erro ao fazer Deploy de Widget

Tempo aproximado para leitura: 00:02:14 min

Ocorrência

Ao exportar uma widget para o ambiente do Fluig e apertar em Finalizar, a exportação não acontece. Não é exibida a mensagem de "Está na fila, aguarde o deploy." e também não é apresentada nenhuma mensagem de erro.

 

No log é retornado esse erro:

2022-11-22 17:20:46,350 ERROR [com.totvs.technology.wcm.web.rest.DeployServiceRest] (default task-3131) Ocorreu um erro ao fazer o upload do arquivo: wcmapplicationcenter.duplicatedresource: com.fluig.wcm.core.exception.DuplicatedResourceException: wcmapplicationcenter.duplicatedresource



Ambiente
TOTVS Fluig Plataforma - WCM - Todas as versões



Causa
O sistema entende que a widget já existe na plataforma pois está realizando o deploy com identificações semelhantes a uma já existente na plataforma.

Solução

Ao criar uma widget, os itens abaixo devem possuir o mesmo nome. Este nome deve ser único, ou seja, não pode ser utilizado em nenhuma outra widget, pois a duplicidade pode causar problemas durante o deploy dos componentes:

  • Nome do widget.
  • Propriedade "context-root" do arquivo jboss-web.xml.
  • Propriedade "application.code" do arquivo application.info.

Importante
Após a inclusão da propriedade os serviços devem ser reiniciados.

A partir da versão Voyager 2.0, as configurações foram migradas dos arquivos domain.xml e host.xml para o standalone.xml. Este artigo se refere às versões anteriores ao Voyager 2.0.
Para mais informações sobre a migração e as diferenças entre as versões, consulte nossa documentação Atualização Voyager (2.0) - O arquivo de configurações da plataforma mudou!

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _