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Fluig - Plataforma - CON - Como solucionar o erro: "Caused by: java.lang.OutOfMemoryError: Java heap space"

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Ocorrência

A plataforma apresenta lentidão durante a navegação entre módulos ou indisponibilidade, e no log é exibida a mensagem:

2023-08-07 00:00:06,620 ERROR [org.jboss.as.ejb3.invocation] (Thread-2702 (ActiveMQ-client-global-threads)) WFLYEJB0034: EJB Invocation failed on component TotvsTechMessageBean for method public void com.totvs.technology.social.jms.service.TotvsTechMessageBean.onMessage(javax.jms.Message): javax.ejb.EJBException: WFLYEJB0442: Unexpected Error
Caused by: java.lang.OutOfMemoryError: Java heap space


Ambiente
TOTVS Fluig Plataforma - Configurações Técnicas - Todas as versões


Causa
Não realizar o ajuste na configuração padrão do uso de memória ou execução de tarefas travadas podem causar cenários onde toda memória disponível para uso na plataforma Fluig é utilizada.

Solução

Para solucionar a ocorrência é necessário verificar os cenários abaixo.

  1. Verifique se as configurações de memória do servidor estão de acordo com o Modelo de dimensionamento. Veja como fazer o ajuste em nosso artigo: Fluig - Plataforma - CON - Como alterar o tamanho de memória que o servidor consome;
  2. Verifique se existe algum Dataset que foi configurado fora do datasource AppDs, ao realizar um desenvolvimento usando o datasource da plataforma a partir da atualização 1.6.5-190514 é indispensável usar o AppDS em vez do FluigDS ou FluigDSRO;
  3. Revise também Desenvolvimentos que foram modificados recentemente e no log procure por tarefas nas quais o tempo de execução é maior do que o esperado, procure pelo texto "executou por" assim é possível filtrar as execuções e verificar quais apresentam um tempo maior de execução.
  4. Após revisar os passos acima faça a limpeza dos arquivos temporários do Fluig, para isso elimine as pastas data, log, servers e tmp. Veja mais sobre em nosso artigo: Fluig - Plataforma - CON - Como excluir as pastas temporárias do diretório de instalação;

Se mesmo após executar o passo a passo a mensagem de erro continue aparecendo no log, entre em contato com o Suporte técnico da TOTVS através do Portal do Cliente e envie as evidências para uma análise mais detalhada da situação.

 

Atenção
Nesse diretório existe a pasta configuration, que não deve ser excluída, pois se trata de uma pasta fundamental para o funcionamento da plataforma. As demais pastas são todas temporárias. Caso a plataforma não as encontre, ela automaticamente recria as pastas.

 

Nota
A partir da versão Voyager 2.0, as configurações foram migradas dos arquivos domain.xml e host.xml para o standalone.xml. Este artigo se refere às versões anteriores ao Voyager 2.0.

 

Para versões Voyager 2.0 o diretório está localizado em: [diretório de instalação do Fluig]\appserver\standalone.

 

Para mais informações sobre a migração e as diferenças entre as versões, consulte nossa documentação Atualização Voyager (2.0) - O arquivo de configurações da plataforma mudou!

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