Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - DES - Cadastro de serviço ocorre Connection timed out: connect

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:04:02min

Ocorrência

Ao Cadastrar um serviço ocorre "Falha ao criar um registro". Ao avaliar o log é exibido o erro:

WSDLToJava Error: org.apache.cxf.wsdl11.WSDLRuntimeException: Fail to create wsdl definition http://127.0.0.1:80/ws/INTEGRATION.apw?WSDL: WSDLException: faultCode=PARSER_ERROR: Problem parsing 'http://127.0.0.1:80/ws/INTEGRATION.apw?WSDL'.: java.net.ConnectException: Connection timed out: connect


Ambiente
TOTVS Fluig Plataforma - Desenvolvimento sobre a Plataforma - Todas as versões


Causa

Esse erro indica que houve um problema ao conectar-se ao arquivo WSDL (Web Services Description Language) no endereço especificado http://127.0.0.1:80/ws/INTEGRATION.apw?WSDL.

O erro java.net.ConnectException: Connection timed out: connect sugere que a tentativa de conexão ao endereço especificado (127.0.0.1 na porta 80) excedeu o tempo limite. Isso pode ser devido a diversas razões:

  1. Indisponibilidade do Servidor: O servidor pode não estar em execução ou acessível no endereço fornecido (127.0.0.1 na porta 80).

  2. Problemas com Firewall ou Rede: Pode haver restrições do firewall ou problemas de rede que estão impedindo a conexão ao endereço especificado.

  3. URL Incorreta: A URL fornecida pode estar incorreta ou digitada incorretamente.

Solução

Alguns pontos podem ser avaliados como:

  • Verifique a Disponibilidade do Servidor: Garanta que o servidor esteja em execução e acessível no endereço especificado (http://127.0.0.1:80).

  • Verifique a URL: Certifique-se de que a URL fornecida esteja correta e acessível a partir do dispositivo onde esse erro está ocorrendo.

  • Verifique as Configurações do Firewall: Se tiver controle sobre as configurações do firewall, verifique se as portas necessárias estão abertas para estabelecer a conexão.

  • Tente a Conexão Novamente: Às vezes, problemas temporários na rede podem causar o timeout. Tente a conexão novamente depois de garantir que o servidor esteja funcionando e a URL esteja correta.

  • Consulte a Documentação: Verifique a documentação relacionada ao serviço ao qual você está tentando se conectar. Pode haver configurações ou requisitos específicos necessários para acessar o WSDL.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _