Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - ANA - Evento beforeSendData é modificado ao criar uma nova versão do processo

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Na mudança de versão do processo, o evento beforeSendData foi modificado.

Ambiente
TOTVS Fluig Plataforma - Analytics - Versão 1.7.0 Lake e superiores.


Causa

Ao salvar um formulário pelo editor de formulários web (Processos → Configurar Processos → [selecionar processo] → Editar → Formulário), o evento beforeSendData é recriado caso algum campo do formulário esteja habilitado para enviar dados para o Analytics. Esse procedimento resulta na perda do evento beforeSendData da versão anterior.


Solução

1. No Analytics, filtrar os dados do relatório pela versão do processo. Isso impede que haja divergências entre duas solicitações apresentadas.

2. Caso seja necessário utilizar um beforeSendData desenvolvido especificamente para o processo, não marcar os campos do formulário como campos a enviar para o Analytics. (vide abaixo).

Desmarque a opção Usar Analytics? dos campos do formulário

 

3. Sempre verificar a ordenação ao remover algum campo da listagem de campos para serem enviados ao Analytics, pois pode haver inconsistências entre o customField que está sendo utilizado para aquele campo (empregar a solução 1).

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _