Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma- CON - Erro 52e no login com protocolo LDAP

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência

Ao tentar realizar o login utilizando a senha do Active Directory é exibido erro de credenciais inválidas.

2023-05-15 10:37:05,575 WARN [org.jboss.security.auth.spi.AbstractServerLoginModule] (default task-15) javax.naming.AuthenticationException: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C090434, comment: AcceptSecurityContext error, data 52e, v4f7c
2023-05-15 10:37:05,604 ERROR [org.jboss.security.auth.spi.AbstractServerLoginModule] (default task-15) Password Incorrect/Password Required: javax.security.auth.login.FailedLoginException: Password Incorrect/Password Required 
at com.totvs.foundation.auth//com.totvs.foundation.auth.AbstractFoundationLdap.login(AbstractFoundationLdap.java:613)

 

Ambiente
TOTVS Fluig Plataforma - Configurações Técnicas - A partir das versão 1.8.0 e 1.8.1.


Causa

Esse incidente ocorre, pois os dados preenchidos na parametrização do protocolo LDAP no arquivo domain.xml podem estar incorretos. O erro 52e do LDAP é relacionado a erros nas credenciais e indica um erro AcceptSecurityContext do Active Directory (AD), que é retornado quando o nome de usuário é válido, mas a combinação de senha e credencial do usuário é inválida. Este é o AD equivalente ao código de erro 49 LDAP. Aqui você pode encontrar outros erros relacionados ao LDAP.

Solução
Nas versões 1.6, 1.7 e 1.8 revise o arquivo de configuração domain.xml que fica disponível no caminho: [diretório de instalação do Fluig]\appserver\domain\configuration\domain.xml e valide está de acordo com a documentação Configuração de autenticação utilizando LDAP.

A partir da versão 2.0, revise o arquivo de configuração standalone.xml que fica disponível no caminho: [diretório de instalação do Fluig]\appserver\standalone\configuration\standalone.xml e valide está de acordo com a documentação Configuração de autenticação utilizando LDAP.

Segue abaixo os pontos que devem ser revisados:

  1. Verifique se a configuração está correta e conforme o tipo de validação que você utiliza para comunicação com seu Active Directory, podendo ser: "Com credencial encriptada", "Com credencial" e "Sem credencial". Por exemplo caso a configuração no servidor do Active Directory exija que o login utilize credenciais é necessário utilizar o trecho com os parâmetros que possuem os campos para o preenchimento do login e senha, só assim funcionamento correto será executado.
  2. O usuário utilizado na configuração precisa ter permissão para visualizar toda árvore de domínio no AD, caso contrário não será possível encontrar o usuário para validar o login.
  3. Garanta que as propriedades de busca configuradas no domain.xml consigam encontrar todos os usuários do domínio, na documentação você pode saber mais sobre Propriedades de Busca LDAP.
  4. Garanta que o cadastro dos usuários no AD e no Fluig utilizem o mesmo padrão, por exemplo: Login: nome.sobrenome, E-mail: nome.sobrenome@suaempresa.com.  É necessário que o e-mail do usuário seja o mesmo no Fluig.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _