Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Erro de senha incorreta ao configurar certificado HTTPS (failed to decrypt safe contents entry)

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência

Ao realizar a configuração HTTPS na plataforma Fluig via tela a senha do certificado aparece incorreta, mesmo inserindo corretamente, apresentando o seguinte log de erro:

Caused by: java.io.IOException: keystore password was incorrect
Caused by: java.security.UnrecoverableKeyException: failed to decrypt safe contents entry: javax.crypto.BadPaddingException: Given final block not properly padded. Such issues can arise if a bad key is used during decryption."}}


Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Todas as versões.

Causa
A criptografia utilizada na geração dos arquivos do certificado digital pode não ser compatível com o Fluig ou a versão 3.0 da ferramenta OpenSSL pode gerar incompatibilidades.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

Passo 1:

Exporte novamente o arquivo do certificado utilizando a tag "-legacy" e "-descert".

openssl pkcs12 -export -out certificate.pfx -inkey private.key -in certificate.crt -certfile ca_bundle.crt -legacy -descert

Importante:

Após realizar o processo acima, acessar a tela de configuração HTTPS e informar o novo certificado gerado (seucertificado-2021.p12). Caso esteja configurando manualmente, clique aqui e siga as instruções no HTTPS utilizando o novo certificado.

Caso mesmo após o ajuste o erro persista é recomendado entrar em contato com a certificadora que emitiu os arquivos, pois cada certificadora tem sua particularidade e foge do escopo do atendimento padrão.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _