Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma- CON - Erro ao criar empresa

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Ao criar uma nova empresa é exibido no log um erro de conexão ao buscar datasource.

2024-04-24 18:07:18,488 ERROR [stderr] (Thread-30 (ActiveMQ-client-global-threads)) com.totvs.technology.foundation.common.exception.FDNCreateException: Erro as buscar datasource: java.net.ConnectException: WFLYPRT0023: Could not connect to remote+http://[IP_DO_SERVIDOR]:9990. The connection timed out


Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Todas as versões

Causa
O pool máximo de conexão configurado no arquivo domain.xml está com o valor padrão ou um valor muito baixo. E ao atingir o limite máximo de conexões perde a conexão com o datasource gerando o erro na criação da empresa.

Solução
É necessário ajustar o valor do pool de conexão no arquivo de configuração e após isso, você deve criar um nova empresa. A empresa criada com erro não pode ser utilizada, pois está comprometida e pode apresentar diversas inconsistências não mapeadas pelo time de produto.

Para ajustar o pool de conexão, é necessário seguir os passos abaixo:


Versões 1.6, 1.7 e 1.8:

  1. Pare os serviços do Fluig
  2. Acesso o arquivo de configuração domain.xml que fica disponível no caminho: [diretório de instalação do Fluig]\appserver\domain\configuration\domain.xml.
  3. Edite os datasources "FluigDS", "FluigDSRO" e "AppDS".
    1. Localize o trecho abaixo em cada uma dos datasources e alterar o valor padrão de acordo com a disponibilidade da sua infraestrutura de ambiente. Abaixo um exemplo com o valor de 100 pools de conexão.
    2.  <pool>
      <min-pool-size>10</min-pool-size>
      <max-pool-size>100</max-pool-size>
      </pool>
    3. Faça a limpeza dos arquivos temporários do diretório de instalação do Fluig.
    4. Apague as duas pastas keys que ficam em [diretório_instalação]\repository\wcmdir\keys e a outra no Volume.
    5. Inicie os serviços do Fluig novamente.
    6. Faça a criação de uma nova empresa.

A partir da versão 2.0:

  1. Pare os serviços do Fluig
  2. Acesso o arquivo de configuração standalone.xml que fica disponível no caminho: [diretório de instalação do Fluig]\appserver\standalone\configuration\standalone.xml.
  3. Edite os datasources "FluigDS", "FluigDSRO" e "AppDS".
    1. Localize o trecho abaixo em cada uma dos datasources e alterar o valor padrão de acordo com a disponibilidade da sua infraestrutura de ambiente. Abaixo um exemplo com o valor de 100 pools de conexão.
    2.  <pool>
      <min-pool-size>10</min-pool-size>
      <max-pool-size>100</max-pool-size>
      </pool>
    3. Faça a limpeza dos arquivos temporários do diretório de instalação do Fluig.
    4. Apague as duas pastas keys que ficam em [diretório_instalação]\repository\wcmdir\keys e a outra no Volume.
    5. Inicie os serviços do Fluig novamente.
    6. Faça a criação de uma nova empresa.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _