Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - DES - Erro wdk/MetaList na criação de novos formulários

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Ao exportar um novo formulário do Eclipse para a plataforma, é exibido o seguinte erro em tela: BMT bean wdk/MetaList should complete transaction before returning.



Ambiente
TOTVS Fluig Plataforma - Desenvolvimentos - Todas as versões


Causa
A situação ocorre devido ao uso de palavras reservadas em campos do formulário, por exemplo: version, documentid, companyid, etc. Ao utilizar esses nomes, a plataforma tentará criar duas colunas com o mesmo código, onde gera o erro da imagem acima.

Exemplo de uso incorreto - Campo documentId
<html>
<head>
    <link type="text/css" rel="stylesheet" href="http://style.fluig.com/css/fluig-style-guide.min.css" />
    <script type="text/javascript" src="/portal/resources/js/jquery/jquery.js"></script>
    <script type="text/javascript" src="/portal/resources/js/jquery/jquery-ui.min.js"></script>
    <script type="text/javascript" src="/portal/resources/js/mustache/mustache.min.js"></script>
    <script type="text/javascript" src="http://style.fluig.com/js/fluig-style-guide.min.js" charset="utf-8"></script>
</head>
<body>
    <div class="fluig-style-guide">
        <form name="form" role="form">
            <input type="text" class="form-control" id="documentId" name="documentId">
        </form>
    </div>
</body>
</html>

O erro também pode ser apresentado após a réplica de um ambiente. No arquivo server.log, será apresentado a causa do erro no log do Fluig, conforme o exemplo abaixo:

ERROR [com.totvs.technology.ecm.workflow.ws.WorkflowEngineService] (default task-89) WFLYEJB0443: EJB 3.1 FR 13.3.3: BMT bean wdk/MetaList should complete transaction before returning.: javax.ejb.EJBTransactionRolledbackException: WFLYEJB0443: EJB 3.1 FR 13.3.3: BMT bean wdk/MetaList should complete transaction before returning.
Caused by: java.lang.Exception: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'ml001030' already exists


Solução
Retire o uso das palavras reservadas no HTML do formulário.

Exemplo de uso correto - Campo formDocumentId
<html>
<head>
    <link type="text/css" rel="stylesheet" href="http://style.fluig.com/css/fluig-style-guide.min.css" />
    <script type="text/javascript" src="/portal/resources/js/jquery/jquery.js"></script>
    <script type="text/javascript" src="/portal/resources/js/jquery/jquery-ui.min.js"></script>
    <script type="text/javascript" src="/portal/resources/js/mustache/mustache.min.js"></script>
    <script type="text/javascript" src="http://style.fluig.com/js/fluig-style-guide.min.js" charset="utf-8"></script>
</head>
<body>
    <div class="fluig-style-guide">
        <form name="form" role="form">
            <input type="text" class="form-control" id="formDocumentId" name="formDocumentId">
        </form>
    </div>
</body>
</html>

Para verificar a lista de todas as palavras reservadas, acesse a documentação: Modelos de Armazenamento de Formulários

Para casos onde foi realizado a réplica do ambiente, abra um novo ticket para a equipe de suporte Fluig.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _