Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - DES - Em alguns exemplos de desenvolvimento surgem o erro 401 - Unauthorized


relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:02:00min

Ocorrência

Ao utilizar alguns exemplos de desenvolvimento disponibilizados no repositório de exemplos ocorre a inconsistência 401 - Unauthorized e a execução é interrompida.

Causa
Isso ocorre porque alguns exemplos utilizam bibliotecas que são disponibilizadas no repositório de artefatos do Fluig no Nexus, que agora é privado e passou a exigir autenticação.

Solução

É necessário solicitar as credenciais de acesso ao Nexus, que permitirá que as dependências dos exemplos sejam baixadas corretamente.

Para isso, abra um ticket para o time de Atendimento Fluig.

Como utilizar as credenciais?

Com as credenciais em mãos, adicione o bloco de código abaixo no arquivo settings.xml do projeto, substituindo:

 

  • "inserir_o_usuário_fornecido" pelo usuário enviado pelo atendimento;
  • "inserir_a_senha_fornecida" pela senha enviada pelo atendimento.
<servers>
  <server>
    <id>nexus</id>
    <username>inserir_o_usuário_fornecido</username>
    <password>inserir_a_senha_fornecida</password>
  </server>
</servers>

Importante
Após a inclusão da propriedade os serviços devem ser reiniciados.

A partir da versão Voyager 2.0, as configurações foram migradas dos arquivos domain.xml e host.xml para o standalone.xml. Este artigo se refere às versões anteriores ao Voyager 2.0.
Para mais informações sobre a migração e as diferenças entre as versões, consulte nossa documentação Atualização Voyager (2.0) - O arquivo de configurações da plataforma mudou!

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _