Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - FDN - Servidor de autenticação não está acessível

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:02:30 min

Ocorrência

Após atualização, foi observado no log a mensagem sendo apresentada diversas vezes:

2024-08-21 17:49:59,403 WARN [com.fluig.api.admin.v1.user.TokenRest] (default task-51) Para utilizar esta API é necessário habilitá-la. Entre em contato com o suporte Fluig.
2024-08-21 17:49:59,404 WARN [com.fluig.component.UserJwtToken] (Timer-67) Could not generate the token with the following information: user: wcmadmin tenant: 0
2024-08-21 17:49:59,404 WARN [com.fluig.core.i18n.client.startup.I18nStartup] (Timer-67) Servidor de autenticação não está acessível


Ambiente
TOTVS Fluig Plataforma - Configurações Técnicas - Todas as versões

Causa
As mensagens ocorrem devido à existência de artefatos antigos dos aplicativos Beta (Pages, Forms e Tasks), que já foram descontinuados, ainda presentes no diretório de instalação do Fluig. Além disso, a empresa não possui a chave que permite o uso do endpoint relacionado ao token JWT cadastrada nos dados adicionais.

Solução
Existem duas possibilidades de solução para esse cenário:

1. Clientes que ainda utilizam os aplicativos Beta:

Atualize o ambiente para a versão 1.8.1-240625 ou superior.
Habilite o uso do endpoint relacionado ao token JWT cadastrando a chave correspondente nos dados adicionais, seguindo os passos abaixo:

  1. Acesse o Fluig com o usuário wcmadmin;
  2. No menu lateral, clique em Painel de controle;
  3. No agrupador WCM, clique em Empresas;
  4. Selecione a empresa para a qual deseja habilitar o uso do endpoint /admin/api/tokens;
  5. Clique em Editar;
  6. Na aba Geral, clique em Cadastrar dados adicionais;
  7. Em Chave, preencha com enable.create.jwt.token.api;
  8. Em Valor, preencha com true;
  9. Clique em Salvar e, na edição da empresa, clique em Salvar novamente.


2. Clientes que não utilizam os aplicativos Beta:

  1. Pare os serviços do Fluig.
  2. Exclua os seguintes artefatos da pasta <instalação fluig>/appserver/system:
    bpm-tasks-war.war
    fluig-brm-war.war
    fluig-forms-war.war
    fluig-storage-war.war
    web-page-core-war.war
    fluig-comments-war.war
  3. Após isso, inicie os serviços da plataforma.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _