Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma- WCM - Integração com banco de dados Progress

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Erro ao tentar realizar a integração do TOTVS Fluig com o Datasul via conexão com o banco de dados Progress, utilizando bibliotecas desatualizadas.


Ambiente
TOTVS Fluig Plataforma - Integração - Todas as versões


Causa

As bibliotecas (.jar) disponíveis para a integração na plataforma estão desatualizadas.


Solução

Atualmente existem apenas dois métodos suportados para realizar a integração de sistemas externos com o Datasul, sendo eles os serviços Datasul REST e o serviço ExecBO

As APIs TOTVS para integração via Datasul REST estão disponíveis em: https://api.totvs.com.br.

Caso opte por continuar utilizando integrações com Progress 12, as bibliotecas podem ser encontradas no diretório de instalação do Progress em seu ambiente. 

As bibliotecas estão localizadas no diretório de instalação do OE12, na subpasta java, por exemplo: c:\dlc122\java. 

Outras bibliotecas podem estar no diretório raiz ou em subpastas específicas do Progress.

Você pode verificar as bibliotecas já utilizadas e, em seguida, localizar a versão atualizada no diretório de instalação do Progress. Substitua a biblioteca no TOTVS Fluig, em: [diretório de instalação Fluig]\appserver\modules\com\progress\main.

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _