Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - BPM - Dados de formulários são perdidos em atividades paralelas

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:00:46 min

Ocorrência
Ao preencher um formulário de forma simultânea em atividades paralelas, a informação enviada por um dos usuários é perdida.

Ambiente
TOTVS Fluig Plataforma - Processos - Todas as versões


Causa
Há uma regra para formulários em atividades paralelas que valida as versões do mesmo. Quando há usuários preenchendo o formulário simultaneamente e um deles envia suas informações, os demais usuários, ao tentar enviar, receberão uma mensagem informando sobre a alteração. Será necessário atualizar o formulário para que todos vejam as alterações.


Como o Fluig não salva informações em tempo real, mas apenas quando os dados são enviados ao banco de dados, essa validação foi criada para evitar a perda de informações durante o processo.

Como a validação funciona, não é possível aplicá-la em um formulário com versão única, pois a versão é substituída a cada movimentação. Já em um formulário versionado, os registros são salvos separadamente, permitindo a aplicação da validação.

Solução
Criar o formulário versionado para esse cenário. Caso seu projeto já esteja em funcionamento será necessário remover a versão única do mesmo e liberar versão/exportá-lo para o servidor.

Na web, acesse Configuração de Processo, acione Propriedades e acesse a aba Formulário:


 

No Eclipse, acesse Propriedades e acione a aba Formulário:


Importante!
Vale lembrar que, para solicitações em andamento não será possível a alteração através da conversão, pois não é possível a conversão de formulários.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _