Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - Configuração de threads ativas no servidor NF-e

 

time.pngTempo aproximado para leitura: 00:01:00 min

 

Dúvida
Como configurar threads ativas no servidor NF-e?

Ambiente
TOTVS Distribuição Linha Winthor - 14 - Faturamento -  A partir da versão 30

Causa

O DocFiscal utilizava uma quantidade de 4 threads fixas e limitada, dessa forma mesmo que o servidor do DocFiscal tivesse uma maior capacidade de processamento simultâneo, esse processamento ficava limitado.

 

Solução

Realizado ajuste para que seja possível configurar a quantidade de threads ativas que o DocFiscal irá utilizar em seu processamento.

1. Para configurar o usuário deverá acessar o menu Formação de Lote, e informar a quantidade no campo Número de treads ativas:

2. Ao lado do nome do campo estará o valor máximo permitido que é calculado de acordo com a capacidade de memória e processamento do servidor.

3. O valor padrão do campo é a metade do valor máximo.

  • Essa alteração irá permitir que o docfiscal processe um volume maior de lotes de nota fiscal simultaneamente, porém irá interferir no desempenho das atividades da máquina no momento do processamento. Recomendamos que essa alteração seja feita junto a uma análise do seu setor de TI.

Importante

  • A fórmula de cálculo da quantidade máxima de threads é:((QTD_CPU * 1) + (QTD_RAM_TOTAL * 2)) / 3 = QTD_THREADS. Entendemos que memória tem mais relevância que CPU, por isso memória tem peso 2;
  • Para uso acima de 4 threads recomenda-se avaliação junto ao DBA da empresa para ampliação do limite de cursores do banco em 500/thread.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _