Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Logística - Linha Protheus - TMS - Ajuste tamanho do campo DL8_ID

time.png Tempo aproximado para leitura: 00:01:20 min

Ocorrência
Erros na integração do Protheus com o Coleta Entrega relacionados a unidade.

Ambiente
TOTVS Logística - TOTVS TMS (Linha Protheus) - Gestão de Transportes (TMS) - Todas as versões

Causa
No coleta entrega, caso a unidade possua um código de mais de 4 caracteres, excede o tamanho do campo DN8_ID - Id SAAS, gerando erros na integração do Protheus com o Coleta Entrega. Esse erro pode ocorrer para as integrações com o Coleta Entrega a partir do Protheus Faturamento, Protheus TMS e Protheus OMS, pois essas utilizam a tabela DN8 - Filiais Externas na integração. 

Solução
O produto liberou uma atualização de dicionário 014657 para atualizar o tamanho do campo DN8_ID - Id SAAS para 10 caracteres, para que permita vincular o código da unidade do Coleta Entrega corretamente. 

Vale reforçar que o layout das integrações será revisado para acatar o tamanho do campo DN8_ID - Id SAAS, mas caso tenha problemas na gravação do histórico da integração na tabela DN5 - Histórico de Integrações, ajuste o layout manualmente para acatar o tamanho do campo DN8_ID - Id SAAS e grave o histórico novamente. 

Anexo

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _