Tempo aproximado para leitura: 00:01:30 min
Ocorrência
Ao realizar acesso ao Logix ocorre o erro: ORA-01400: CANNOT INSERT NULL INTO ("LOGIX"."LOG_DADOS_SESSAO_LOGIX"."SID")
Ambiente
Framework - Framework (Linha Logix) - Administração Logix - Todas as versões.
Causa
Esse erro ocorre porque o Logix passou a consultar informações que não estão disponíveis em versões mais antigas do Oracle, ocasionando a falha de autenticação.
Solução
A partir do pacote 12.1.2407, ambientes que utilizam versões do banco de dados Oracle inferiores à 19 passaram a apresentar falhas de login no sistema Logix.
O problema afeta apenas ambientes que utilizam versões de Oracle já descontinuadas.
Para contornar essa falha, é necessário criar uma VIEW no banco de dados. Abaixo, segue o script para criação da VIEW:
CREATE VIEW PRODUCT_COMPONENT_VERSION AS
SELECT substr(ver.banner,1, instr(ver.banner,'Release')-2) product, inst.version, inst.version_full,
substr(ver.banner, instr(ver.banner,'-')+1 , 30) status
FROM v$version ver, v$instance inst
WHERE banner LIKE 'Oracle%'
Importante
A VIEW é apenas um paliativo, sugerimos realizar a atualização do banco de dados Oracle para versão 19 ou superior, para que o ambiente do Logix possa seguir recebendo atualizações conforme necessidade e consequentemente suporte conforme produtos homologados.
Saiba mais
Banco de Dados Homologados
0 Comentários