Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Varejo - Moda - PES - PESFC056 - Nenhum agente externo ativo!

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
No módulo Pessoa, ao tentar realizar a consulta de estatística do cliente através do componente PESFC056 - Consulta Estatística do Cliente é apresentada a ocorrência: Nenhum agente externo ativo!

pes.png

Ambiente
TOTVS Varejo - Moda - Pessoa

Causa
Esse incidente ocorre, pois não há configuração de agente externo ativo.

Solução

Para realizar a configuração do agente externo para comunicação com a API(V2), realize os seguintes passos:
1. Acesse no sistema TOTVS Moda, o componente INTFM033 - Manutenção de Agente Externo de Integração. O campo Código agente externo será gerado ao término do cadastro automaticamente após salvar utilizando a tecla F3;

intfm033.png2. Informe o número da empresa no campo Empresa, em seguida no campo Tipo aplicação, informe TOTVS Moda API V2;
3. Informe no campo Tipo ambiente, qual ambiente está sendo configurado o agente externo;
4. Informe no campo Usuário e Senha, usuário e senha válidos, com o tipo de privilégio Padrão, cadastrado através do componente ADMFM026 - Manutenção de Usuário;

Observação: Para que a consulta seja realizada corretamente, o usuário criado no ADMFM026 deve possuir empresas liberadas. Esta liberação pode ser realizada diretamente no ADMFM026, pelo botão Login empresa -> ADMFM029 - Manutenção Login por Empresa:

2024-11-27 08_54_30-TOTVS Moda.png
5. Informe no campo Tenant, o nome do tenant cadastrado no ambiente. O tenant é fornecido pelo setor comercial do TOTVS Moda após as devidas liberações e pode ser consultado através do componente LOGFC006 - Consulta Usuário para Api - Cliente, no campo Client_id;
logfc006.png

6. Informe no campo URL base, a url https://www30.bhan.com.br:9443/ utilizada para comunicação da API(V2). Para obtenção da URL base em caso de servidor próprio, verificar com administrador do servidor.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _