Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Could not connect to server for database banco, errno 0. (1432)

time.png Tempo aproximado para leitura: 00:02:33 min

Ocorrência
Na execução da rotina apresenta a mensagem em tela ou em log: Could not connect to server for database banco, errno 0. (1432)

Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge – Versão 12

Causa
O erro 1432 traz um erro de Sistema operacional, a lista de erros mais comum:
Errno 0: O Sistema operacional não sabe qual erro ocorreu;
Errno 2: Arquivo não foi encontrado, referência ao service pode estar errada;
Errno 5: Permissão negada, pode estar sem acesso ao servidor;
Errno 13: Permissão negada, pode estar sem acesso ao servidor.

O erro 1432 ocorre quando é utilizado os parâmetros básicos de conexão cliente-servidor. Esse erro se aplica basicamente sobre o parâmetro -S que identifica o serviço no qual o banco de dados será servido.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Verificar se o Banco de Dados está ativo, especialmente o banco que apresentado na mensagem de erro. Quando quando é carregado gera um arquivo com a extensão banco.lk junto com os bancos no diretórios onde os bancos estão fisicamente;

2. Conferir na conexão dos bancos no arquivo .pf e no cadastro dos bancos no programa BTB962AA se os parâmetros estão corretos conforme a carga dos bancos como: -S -H -db e -ld, veja no Saiba mais informações de onde estão os bancos no produto Datasul for THF;

3. Verificar junto com a Infra possível bloqueio como firewall, antivirus que possa está bloqueando a conexão do banco via client-server.

Saiba mais
Conexões banco de dados no produto Datasul Framework - Linha Datasul - TEC - Onde estão localizadas as conexões de banco de dados no ambiente Datasul for THF
Informações complementares em:
Error 1432 with 'errno 0' when try to connect client/server: First things to rule out.
1432 error with errno 0 connecting from PC clients to database on Linux

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _