Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - DLL Error : libnsl.so.1: cannot open shared object file: No such file or directory (8014)

time.png Tempo aproximado para leitura: 00:01:32 min

Ocorrência
No log do PASOE apresenta a mensagem DLL Error : libnsl.so.1: cannot open shared object file: No such file or directory (8014)

Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge - Versão 12

Causa
Para o Progress OpenEdge 12.X é necessário instalar uma biblioteca libnsl.so.1 em Sistema Operacional Linux.

Solução
Se o PASOE estiver no servidor Linux é necessário instalar uma biblioteca através do comando:

yum install libnsl

No Client que executa a rotina, efetuar a cópia das dlls abaixo:

Dir_Instalação_Progress/bin/icuuc-psc.dll
Dir_Instalação_Progress/bin/icudata-psc.dll
Dir_Instalação_Progress/bin/icui18n-psc.dll
Dir_Instalação_Progress/bin/proxml.dll
Dir_Instalação_Progress/bin/system/*.*

Para o diretório C:/Windows/System32, sobrepondo os que já existem. Se for 64 bits, fazer o mesmo processo, porém incluindo os arquivo no diretório C:/Windows/SysWOW64

Saiba mais
Informações referente a instalação do Progress OpenEdge 12.X no Linux:
https://docs.progress.com/pt-BR/bundle/openedge-install/page/System-requirements-and-supported-platforms.html
Informações adicionais sobre o comando:
OpenEdge processes fail to start with errors 8013 and 8014 on Linux RHEL/CentOS 8.x distributions

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _