Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - INTEGRAÇÃO Carga inicial não respeita filial logada para tabela compartilhadas.

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Via carga inicial quando tenho uma tabela compartilhada no Protheus, esta sendo enviado informações apenas para a primeira filial.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Protheus Release 12.1.33 ou Superior.

Causa
Isso ocorre pois alguns sistemas se utilizam da Tag "Banchid" para efetuar a integração, como por exemplo o sistema Quirions.


Solução 

Conforme analisado internamente junto ao time de produto, a tag "BranchId" quando efetuado a integração pela alteração via rotina, será preenchida com a filial posicionada no momento.

Porém quando realizado via carga inicial no configurador, durante o sincronismo a tag "BranchId" será preenchia com a primeira filial ativa disponível no sistema, sendo assim, a filial que vc logou para iniciar o sincronismo não interfere.


O comportamento do sistema vai trazer apenas da primeira, pois no conceito de tabela compartilhada, como os dados são os mesmos, não há a necessidade do enviado de todas as filiais de maneira separada.

Dado isso para ter o comportamento desse, se faz necessário o mesmo tipo de compartilhamento de tabela em ambos sistemas.


Observação: Carga inicial é uma funcionalidado do Framework, sendo assim, ela tem um comportamento diferente da rotina do estoque.


Saiba mais:

Clique aqui e veja mais artigos sobre Integrações no Estoque

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _