Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - SIGAFAT - Erro ao acessar o Smart View Invalid object name 'SX10'.

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao acessar o Smart View, na tela do Protheus é apresentada a mensagem "Erro na importação do recurso, verificar os logs do Smart view e do Protheus", ao validar os logs, é registrado o seguinte erro:

Erro no objeto de negócio 'totvs.protheus.backoffice.com.smartview.integratedprovider.purchasegroupsreportsbusinessobject'
Invalid object name 'SX10'.


Ambiente
Cross Segmentos - Backoffice Protheus - SIGAFAT - Todas as versões

Causa
O Objeto de Negócio referenciado no erro é responsável por verificar tabelas como a de Peruntas (SX1) no ambiente vinculado ao REST.

Na configuração do REST existe a chave "PrepareIn" que é responsável por estabelecer qual Empresa/Filial esta vinculada ao REST.

Caso a chave "PrepareIn" não esteja configurada devidamente, é possível que o Smart View tente localizar a tabela "SX10", por exemplo, ao invés de pesquisar por "SX1010" (Nome da tabela com o código da empresa).

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Realize o ajuste da chave "PrepareIn", conforme documentação REST com ERP Microsiga Protheus

2. Verifique as demais configurações através da documentação: Configuração do SmartView

3. Caso o problema persista, entre em contato com o time de Suporte Framework da TOTVS.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _