Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Integração PIMS x Protheus erro "array out of bounds [3] of [0] on PSWCHAVE(SIGAPSW.PRG)"

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:02:21min

Dúvida
Ao realizar a integração do sistema PIMS para o Protheus ocorre mensagem de erro :

INTEGDEF RETURN ERROR --> [array out of bounds [3] of [0] ] 
|array out of bounds [3] of [0] on PSWCHAVE(SIGAPSW.PRG) 13/08/2024 15:56:59 line : 1700
|Called from USRRETNAME(MATXALC.PRX) 13/06/2024 17:21:57 line : 495
|Called from MATI105(MATI105.PRX) 11/05/2022 16:42:23 line : 358

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa
Normalmente esse erro está relacionado com o Cadastro de Usuário que está gerando a movimentação, geralmente em caso de acionamento do fonte MATI105 que gera a solicitação ao armazém.

Solução

Ao coletar a ultima chamada do fonte MATI105 linha 358 |Called from MATI105(MATI105.PRX) 11/05/2022 16:42:23 line : 358 . Verificamos que é realizada uma validação relacionada ao usuário: 


 
Essa função UsrRetName retorna o usuário do sistema para maiores detalhes clique aqui. 
 

Após essa chamada é realizada uma validação no fonte MATXALC linha 495 |Called from USRRETNAME(MATXALC.PRX) 13/06/2024 17:21:57 line : 495 .Verificamos que nessa validação continua sendo validado questões de usuário:

 

 
Essa condição que verifica se um usuário específico existe em um banco de dados de usuários, e caso ele exista, atribui uma chave de acesso, para maiores detalhes sobre a função PsqSeek clique aqui
 

E por fim o erro estoura na função PSWCHAVE : array out of bounds [3] of [0] on PSWCHAVE(SIGAPSW.PRG) 13/08/2024 15:56:59 line : 1700

 
Porém essa validação não temos acesso por ser um fonte de LIB, mas pesquisando sobre SIGAPSW verificamos que tem relação com os arquivos de senhas sigapss.spf 
 
Sabendo dessas validações acima, entendemos que o problema está relacionado a usuário no momento de realizar a movimentação da integração, sendo necessário entender se está implantando o sistema e é necessário algum cadastro especifico na parte do PIMS, ou se foi realizada alguma mudança relacionada ao usuário.

 

Saiba mais:

Clique aqui e veja mais artigos sobre Integrações no Estoque

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _