Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Falha ao enviar apontamento de serviço de oficina para integração variable is not array - Type [U] on MATI105

time.png Tempo aproximado para leitura: 00:02:12min

Ocorrência
Ao realizar a Integração Protheus x PIMS de Apontamento de Serviço de Oficina, é retornado o erro "Falha ao enviar apontamento de serviço de oficina para integração variable is not array - Type [U] on MATI105":



Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa
Esse erro normalmente é apresentado quando dentro do Processo de Solicitação ao Armazém (MATA105) é gerado uma Solicitação de Compra (MATA110) porém o Adapter não foi cadastrado ou está incorreto. 

Solução
Ao analisar o Manual do PIMS, relacionado a Integração de Serviço de Oficina, podemos ver o seguinte trecho:
 

 

Ou seja, dependendo do tipo de movimentação que está sendo gerado no PIMS, será gerado uma Solicitação de Compras no Protheus, ao realizar a Integração.


Clique aqui para visualizar o Manual completo.
 
Sendo assim é necessário ter os Adapters Cadastrados no Protheus para que todos os processos funcionem provavelmente o processo que está fazendo no PIMS é gerado solicitação de compra e o Adapter não existe, gerando erro.

 

Segue abaixo exemplo do cadastro:
 

 

 

 

Caso tenha dúvidas sobre qual processo deve ou não gerar a solicitação de compras recomendamos abertura de um chamado pontual com o Suporte do Sistema PIMS. 

 

Saiba mais:

Clique aqui e veja mais artigos sobre Integrações no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _