Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Logix - BI - O serviço não inicia com Sistema Operacional Windows 2022

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Ao substituir para um servidor com Windows 2022 o serviço do Windows do Logix BI não inicia, também não funciona pelo atalho_inicia_bi.bat.

Ambiente
Framework - Framework (Linha Logix) - Inteligência Empresarial (BI) - Versão 12

Causa
O Tomcat 8.0.33 utilizado para Logix não é homologado para o Windows 2022, é necessário atualizar para o Tomcat 9

Solução
Para a atualização do Tomcat 9 baixe o pacote que está no Portal de Clientes, link no Saiba mais.

Após atualização do pacote plataforma no ambiente, salvar o arquivo bi.war na pasta webapps do Tomcat.

Para instalar o Tomcat como serviço do Windows é necessário:

1. Abrir um prompt de comando como administrador, em seguida entrar no diretório C:\TOTVS\BI\tomcat\apache-tomcat-9.0.60\bin e executar o comando service install tomcat9

Tomcat 9 logix BI.png

2. Executar como administrador o aplicativo tomcat9w.exe que também está no diretório C:\TOTVS\BI\tomcat\apache-tomcat-9.0.60\bin. Na guia Java deve ser configurado o caminho da Virtual Machine. Em Java Options deve ser adicionado a opção
-Dconfigdir=C:\TOTVS\BI\configuracoes e os campos Initial memory pool e Maximum memory pool ambos como 1024.

Tomcat 9 logix BI 2.png

 

3. O serviço terá como nome de exibição Apache Tomcat seguido de sua versão. Exemplo: Apache Tomcat 9.0 tomcat9. Para alterar o nome de exibição vai até a guia General e no campo Display name altere para o nome, exemplo: Logix BI.


Tomcat 9 logix BI 3.png

Em propriedades do serviço é possível configurar para o tipo de inicialização automática, assim o Logix BI estará disponível sempre que o servidor carregar o Windows.

Saiba mais
Download do pacote da plataforma Tomcat 9 para o Logix BI em Tomcat 9 para Logix BI

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _