Tempo aproximado para leitura: 00:03:00 min
Ocorrência
Ao acessar a rotina de Cadastro de Produtos (MATA010) os botões "Incluir", "Alterar", "Visualizar" e "Excluir" não são apresentados
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAEST - Todas as versões
Causa
Isso pode ocorrer caso o fonte padrão (MATA010.prw) tenha alguma interrupção em sua execução, essa interrupção pode ser causada por:
- Pontos de Entrada executados na abertura da tela de Cadastro de Produtos;
- Caso exista um fonte, customizado, compilado com o mesmo nome da rotina (MATA010.prw)
Solução
Esses foram dois cenários que verificamos a ocorrência do incidente. Caso ocorra em seu ambiente, realize o seguinte processo:
1. Retire o ponto de entrada ou rotina customizada de seu RPO e realize um novo teste;
2. Os pontos de entrada ficam guardados no Custom.rpo (RPO Custom):
- Em ambiente de Homologação, após os devidos Backups dos dados, é possível retirar o RPO Custom da pasta;
- Assim o sistema gera um RPO Custom novo e não executa as customizações, permitindo testar se elas estavam afetando a rotina padrão.
Saiba mais:
Clique aqui e veja mais artigos sobre Cadastros e Configurações Gerais no Estoque
0 Comentários