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Cross Segmentos - Backoffice Protheus - SIGAFAT - Legenda laranja na rotina Exclusão Documento de Saida


time.png Tempo aproximado para leitura: 00:05:00 min

 

Ocorrência
Ao tentar excluir documento de saída foi retornado a legenda laranja e não exclui.

Ambiente
Cross Segmentos - Backoffice Protheus - SIGAFAT – Todas as versões

Causa 
A legenda laranja significa "Aguardando Cancelamento", ou seja, um problema de comunicação com SEFAZ ou SPED Protheus, pois o job só exclui ou dá retorno se obter validação pelo SEFAZ

Solução
 

1 - Tenha em mãos a chave NFE (campo "Chave (F2_CHNVFE)")

Valide na SEFAZ para ver se está na SEFAZ HOMOLOGAÇÃO ou SEFAZ PRODUÇÃO. A mesma chave só pode estar em um ambiente SEFAZ

Coloque a chave XML (campo F2_CHVNFE do cabeçalho da nota fiscal de saída) na Homologação Sefaz e consulte para ver se aparece:
https://hom.nfe.fazenda.gov.br/portal/principal.aspx 

Coloque a chave XML (campo F2_CHVNFE do cabeçalho da nota fiscal de saída) na Produção Sefaz e consulte para ver se aparece:
https://www.nfe.fazenda.gov.br/portal/principal.aspx

Em qual ambiente retornar, é o ambiente em que a nota fiscal de saída foi transmitida.

 

2 - Vá na rotina "NFESEFAZ > Outras Ações > NFe"

Verifique se o pergunte "Ambiente ?" está configurado igual onde está transmitido a nota.

Se a nota foi transmitida em homologação tem de estar "2-Homologacao", se foi transmitida em produção o pergunte tem de estar "1-Producao": 

 

3 - Se for NFe, consulte no site do órgão SEFAZ (https://www.nfe.fazenda.gov.br/portal/disponibilidade.aspx) do estado do cliente, se for NFs, consulte o site da prefeitura do estado do cliente.

Veja se os serviços para o estado do cliente da nota fiscal de saída estão ativos.

Caso não estejam, será necessário aguardar o restabelecimento dos serviços para tentar processar a exclusão novamente.

Observação: Interrupções nos serviços da Sefaz ou da Prefeitura não são de responsabilidade da TOTVS, sendo necessário entrar em contato diretamente com o órgão responsável.


4 - Reavalie a configuração do FATJOBNFE, veja se ele foi configurado o JOB e HORÁRIOS em chaves no "appserver.ini" ou pelo "Schedule" do configurador (SIGACFG)

A - Se está configurado nas chaves do appserver.ini e só tem uma filial usando o FATJOBNFE:

FATJOB_FILIAL_UNICA.png

 

B - Se está configurado nas chaves do appserver.ini e tem mais de uma filial usando o FATJOBNFE:

FATJOB_VARIAS_FILIAIS.png

 

C - Se está configurado corretamente o "Schedule do configurador":

schedule.png

OBS 1: Faça isso para cada filial (caso esteja usando o FATJOBNFE em mais de uma)

OBS 2: Importante ressaltar que a configuração do Schedule tem o consumo de licenças. 

O JOB precisa estar configurado corretamente, consulte aba Configuração: Job para exclusão documento de saída (MATA521) - FATJOBNFE

 

5 - Verifique se o serviço do Protheus TSS X Sefaz está ativo, para isto acesse a rotina "NFESEFAZ".

Caso apresente a mensagem abaixo significa que o TSS está com o serviço parado, é necessário habilitar e processar a exclusão novamente:

 

image (1).png

OBS: Não conseguindo resolver o erro do tópico acima (5), contate a Equipe Protheus SPED

 

6 - Parâmetros MV_CANCNFE (para notas de venda) e MV_CANNFSE (para notas de serviço)

PARAMETROS.png

Caso esses parâmetros estejam com filial em branco, TODAS as filiais da empresa tem de ter a configuração do FATJOB.

Se a filial estiver preenchida, só basta realizar a configuração do FATJOBNFE para aquela filial (no appserver.ini ou schedule)

OBS: Pode ser que esteja preenchido uma filial que não possuam intenção de ter o FATJOBNFE e terem de retirar, ou, caso não usem o FATJOBNFE em todas as filiais, criar o parâmetro por filial só nas filiais que utilizam.

 

7 - Atualize a requisição no documento de saída.
Vá na rotina "MATA521A - Exclusão dos documentos de saída" > Outras ações > "Atualizar" 

OBS: Caso fique diferente de laranja após o procedimento acima, contate a Equipe Protehus SPED para demais informações!

 

8 - O erro permaneceu?

Caso o erro permaneça, envie ao suporte:

  • Print de todos os tópicos (1, 2, 3, 4, 5 e 6):

  • Conteúdo do campo "Flag de Impressao (F2_FIMP)" da nota com legenda laranja

  • Conteúdo do campo "Status (F2_STATUS)" da nota com legenda laranja

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