Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - FAS - Divergência Relatório Situação Geral em Excel

time.png Tempo aproximado para leitura: 00:01:50 min

Ocorrência
Como avaliar situação em que os valores da saída em planilha, não correspondem aos dados listados no relatório?

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) – Ativo Fixo (FAS) – Versão 12

Causa
Na parametrização da opção de geração da planilha, sugere-se o uso de ponto e vírgula como delimitador. Porém os interpretadores podem utilizar vários tipos de caracteres predefinidos como delimitadores, além do ponto e vírgula, podem considerar as aspas duplas  ou vírgula.
Se estes caracteres delimitadores constarem em campos, como descrição do bem por exemplo, pode justificar problema na visão em planilha. 

Solução
As opções de ajuste são:
1 - Antes de abrir o arquivo gerado pelo produto, ajustar parametrização do interpretador excel ou libre office, para considerar somente o delimitador padrão, informado na parametrização da saída em planilha, como no programa FAS342 - Situação Geral do Patrimônio (prgfin\fas\fas342aa.r)

fas342-planilha.jpg

2 - Abrir o arquivo planilha, gerado pelo programa, em um editor texto. Verificar existência de caracteres especiais que possam ser associados ao deslocamento na visão em formato planilha, exemplo:

3 - Editar o bem em questão e eliminar os caracteres causadores do deslocamento ou dos dados agrupados com registros de vários bens em mesma linha. Ao optar pelo ajuste dos dados do bem, como descrição do bem, acessar FAS701 - Manutenção de bens (prgfin\fas\fas701aa.r). 

Importante
Se o problema persistir ou não identificar a causa do problema, exportar a faixa de bens antes e após do ponto de deslocamento da visão em planilha. Encaminhar também o arquivos  planilha e relatório texto. 

Saiba mais
Para exportar dados dos bens acessar Cross Segmentos - Linha Datasul - FAS - Exportador Ativo Fixo.
Após mensagem de término de processamento, compactar a pasta ems5_dump antes do envio. 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _