Tempo aproximado para leitura: 00:02:10 min
Ocorrência
No log do Tomcat apresenta a mensagem não existem sessões (Agentes) disponíveis ao conectar com o PASOE.
Ambiente
Framework - Framework (Linha Datasul) - PASOE - A partir do OpenEdge 12
Causa
A mensagem ocorre quando o Tomcat não consegue se conectar com o PASOE.
Solução
Para solucionar essa ocorrência, consulte os seguintes passos com seu ambiente:
1) Ordem de inicialização dos serviços na seguinte ordem:
- Banco de Dados;
- PASOE;
- Tomcat.
2) Utilização da porta correta do PASOE na URL de conexão do Tomcat:
As requisições realizadas ao PASOE são requisições HTTP e devem ser realizadas neste formato:
http://servidor:porta/apsv
A porta de acesso pode ser identificada através do arquivo conf\catalina.properties, localizado no diretório onde está instalada a instância do PASOE:
psc.as.http.port=9001
psc.as.https.port=9011
Neste formato, considerando um servidor de nome DatasulApp a URL de acesso seria essa:
http://datasulapp:9001/apsv
3) Arquivo conf\context.xml da instância do Tomcat:
Nesse arquivo localize a propriedade totvs.appserver e altere o valor para o endereço http://<servidor-pasoe>:<porta>/apsv, exemplo:
<Environment name="totvs.appserver" type="java.lang.String" value="http://localhost:8920/apsv"/>
O outro local onde essa informação deverá ser atualizada é no programa BTB962AA - Parâmetros do Foundation, na aba Servidores para cada uma das empresas configuradas, exemplo:
O formato do preenchimento pode ser PASOE, como abaixo:
http://meuServer:8085/apsv
Importante
No cadastro da URL do PASOE ou até no arquivo conf\context.xml cuide para não deixar espaços em branco no início da URL.
0 Comentários