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Cross Segmentos - Backoffice Protheus - SIGAFAT - Faturamento com endereço bloqueado (BE_MSBLQL)


time.png Tempo aproximado para leitura: 00:04:00 min

Ocorrência:
Ao tentar faturar um Pedido de Venda onde os itens do pedido controlam endereço, e entre esses itens, um deles esteja com o endereço bloqueado pelo campo BE_MSBLQL, caso não seja informado o endereço no campo C6_LOCALIZ, o sistema permite que seja utilizado o saldo do endereço bloqueado.

Ambiente:
Cross Segmentos - Backoffice Protheus - SIGAFAT - Todas as versões

Causa:

Sobre os campos _MSBLQL e _MSBLQD:

  • Somente serão tratadas tabelas de cadastro e que sejam tabelas pai. Exemplo: Tabela SB1 pode ser validada mas não as tabelas SB5 e SBZ que são suas filhas;
  • Tabelas de movimento não serão tratadas;
  • A validação será realizada somente em tela, através da validação de campo (X3_VALID) com a função ExistCPO();
  • Rotinas de processamento que utilizarem tabelas de cadastro não realizarão a validação do bloqueio do registro;
  • Telas que não estiverem executando a validação de bloqueio do registro, serão tratadas como melhoria no produto.
  • O processo de definição do endereço, quando não informado diretamente no campo (o qual possui o valid para preenchimento na SC6) é disparado e definido para modulo de estoque.


Solução:

O Ponto de Entrada MTSLDLOT  pode ser utilizado para não permitir a utilização do lote, seu retorno é lógico e iria barrar o consumo deste determinado lote.

Caso necessite utilizar outros pontos de entrada, abaixo indicamos alguns para uso:

Saiba mais:

Uso e comportamento dos campos _MSBLQL e _MSBLQD

MTSLDLOT - Ponto que permite consultar os dados do produto com saldo por lote ou saldo por endereço

 

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Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

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Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

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Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

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