Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Erro 18626 em banco de dados Progress OpenEdge com CDC habilitado

time.png Tempo aproximado para leitura: 00:01:01 min

Ocorrência
O erro 18626 é exibido em bando de dados Progress Openedge em operação que envolve a feature Change Data Capture.

Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge - Todas as versões

Causa
O cache utilizado pelo CDC está com um valor muito baixo. Quando este problema ocorre, a mensagem abaixo é exibida em tela ou no clientlog:

Cannot perform this operation because the database CDC cache is too small. (18626)


Solução

Incremente o parâmetro -cdcsize para cada banco de dados no script de carga para um valor maior que o atual. Para ambientes com CDC habilitado o valor default é 2000.

Para incrementar o valor online utilize o comando abaixo como exemplo:

proutil nomedobanco -C increaseto -cdcsize 20000


Saiba mais

Mais detalhes sobre o parâmetro -cdcsize estão disponíveis neste link: CDC cache size (-cdcsize)

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _