Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

RH - RM - FOP - eSocial - Ao ativar o Middleware ocorre o erro: Não foi possível ativar a integração com o Middleware pois existem eventos na fila pendentes de retorno do TAF (status 3 e 4)

RH - RM - FOP - eSocial - Ao ativar o Middleware ocorre o erro: Não foi possível ativar a integração com o Middleware pois existem eventos na fila pendentes de retorno do TAF (status 3 e 4)

time.png Tempo aproximado para leitura: 00:02:30 min

Ocorrência
Ao ativar o Middleware ocorre o erro Não foi possível ativar a integração com o Middleware pois existem eventos na fila pendentes de retorno do TAF (status 3 e 4). Antes da ativação do Middleware é necessário finalizar o envio dos mesmos através do TAF e atualizar o status na fila do RM.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Folha de Pagamento - eSocial - Todas as versões

Causa
O erro ocorre pois uma das premissas para Ativação do Middleware é não possuir eventos pendentes de atualizações, com status 3 e 4.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Identifique os eventos na fila de eventos, ou realize as consultas no banco de dados para identificar esses eventos:
Consulta 1 - FILA DE EVENTOS: SELECT STATUS, * FROM PESOCIALEVENTOS WHERE STATUS = 3 OR STATUS = 4
Consulta 2 - FILA DE EVENTOS COMPLEMENTAR: SELECT STATUS, * FROM PESOCIALEVENTOSCOMPL WHERE SATUS = 3 OR STATUS = 4
2. Após identificar os eventos, será necessário realizar uma avaliação interna, se os eventos devem ser transmitidos ou poderão ser excluídos da fila;
3. Após conferir todos os eventos, realize a ativação novamente. 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _