Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice (Linha Protheus) - SIGAEST - SB2: DB error (Insert): -37 File: SB2 - Error unique constraint CRIASB2

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao realizar a inclusão de uma das movimentações: Pedido de Compra / Solicitação de Compra / Documento de Entrada / Pedido de Venda / Documento de Saída, o sistema está gerando um error.log na função "CRIASB2" indicando: SB2 - Error unique constraint

Ambiente
Cross Segmentos - Backoffice (Linha Protheus) - SIGAEST - Todas as versões

Causa
Este erro acontece quando o sistema identifica que o produto não possui um registro, para o armazém selecionado, na SB2, porém quando tenta realizar inclusão, o banco de dados identifica que o registro já existe.

Essa inconsistência pode ocorrer por alguns motivos:

  • Diferença no tamanho dos campos de código do Produto: sistema faz o Seek (Pesquisa da existência do produto na SB2) a partir de três informações:
    • Filial
    • Código do Produto
    • Armazém

  • Uso incorreto do Ponto de entrada "CRASB2":


Solução

Para solucionar essa ocorrência, realize os seguintes passos:

  1. Verifique o tamanho dos campos que o sistema usa para pesquisa:
    • Principalmente os campo de Código do Produto e Código do Armazém, sempre comparando com as tabelas SB1 e SB2, os campos devem possuir o mesmo tamanho e máscara. Exemplo: se estiver incluindo um Pedido de Compras, verifique se os campos de código de produto e código do armazém da tabela SC7, estão com o mesmo tamanho e máscara dos campos das tabelas SB1 e SB2.
  2.  Verifique se utiliza o ponto de entrada CRIASB2: Grava informações no registro SB2
    • Caso utilize, realize um teste desabilitando o ponto de entrada e verifique se o problema persiste.

 

Saiba mais:

Clique aqui e veja mais artigos sobre Movimentações no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _