Tempo aproximado para leitura: 00:01:30 min
Ocorrência
Ao realizar qualquer requisição na API do sistema RM, é apresentado o erro abaixo:
{
"code": "FW004",
"message": "Alias do banco de dados não encontrado !",
"detailedMessage": "",
"helpUrl": "",
"details": null
}
Ambiente:
Cross Segmentos - Backoffice RM - Integração - Todas as versões.
Causa:
Este erro ocorre, pois a Tag DefaultDB dos arquivos .config dos serviços de Host, estão diferentes do nome do Aliás da Base de dados.
Solução:
Para que o erro não seja apresentado é preciso verificar se o Nome do Alias da Base de dados esta correto, igual ao nome da tag DefaultDB dos arquivos .config do ambiente.
Segue exemplo de validação:
Conforme print acima, no arquivo .config do "RM.Host.Service.exe.config" a tag DefaultDB estava com o nome "CorporeRM", entretanto no cadastro do Aliás o nome definido foi "CorporeRM_TESTE".
Com isso ao tentar consumir qualquer requisição na API será apresentado o erro:
"message": "Alias do banco de dados não encontrado !"
Então é preciso realizar o ajuste para que a tag DefaultDB e o Alias tenham o mesmo nome, conforme ajuste abaixo:
Importante
Lembre de validar se não existem espaços em branco antes ou após o cadastro do nome do Aliás, pois também pode ocasionar este erro:
Após o ajuste a API será consumida corretamente.
0 Comentários