Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - REINF - Erro de schema: Element "paisResidExt": [facet "pattern"] The value "0" is not accepted by the pattern "\d{3}"

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Erro de schema ao gerar evento para Reinf: Element "paisResidExt": [facet "pattern"] The value "0" is not accepted by the pattern "\d{3}".

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - REINF - Versão 12

Causa
Esse incidente ocorre, pois não foi informado o código fiscal do país.

Solução
Para solucionar essa ocorrência, realize a alteração diretamente no módulo Fiscal ou na origem dos dados no Contas a Pagar:

Alteração diretamente no módulo MLF (Configurador Layout Fiscal):

1. Efetue a alteração do registro no programa LF0203;

 


2. Informe o código fiscal do país de acordo com a tabela disponibilizada pela Receita Federal na seção de download de layout no site da REINF (http://sped.rfb.gov.br/pasta/show/2133), efetue o download do layout atual e verifique o arquivo Anexo I - Tabelas;

R-4010-0:

 


R-4020-0:

 


3. Após alteração efetue novamente a geração do evento pelo programa LF0401 ou LF0403.

Alteração no Contas a Pagar:

1. Informe o código fiscal do país de acordo com a tabela disponibilizada pela Receita Federal na seção de download de layout no site da REINF (http://sped.rfb.gov.br/pasta/show/2133), efetue o download do layout atual e verifique o arquivo Anexo I - Tabelas;

O código do país é informado no cadastro do país conforme detalhado no artigo: Cross Segmentos - Linha Datasul - APB - REINF - Eventos R-4010 e R-4020 - campos fornecedor estrangeiro

2. Após alteração efetue novamente a extração dos dados pelo programa LF0400.

3. Após a extração efetue novamente a geração do evento pelo programa LF0401 ou LF0403.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _