Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro na "validação do campo 'indSubstPatr' Valores válidos: 1,2" ao transmitir XML S-1280 para o governo


time.png Tempo aproximado para leitura: 00:03:00 min.


Ocorrência
Ao transmitir o evento S-1280, ocorre o erro de Schema. Erro de schema: Element '{http://www.esocial.gov.br/schema/evt/evtInfoComplPer/v_S_01_02_00}indSubstPatr': [facet 'enumeration'] The value '0' is not an element of the set {'1', '2'}.

Element '{http://www.esocial.gov.br/schema/evt/evtInfoComplPer/v_S_01_02_00}indSubstPatr': 
'0' is not a valid value of the atomic type '{http://www.esocial.gov.br/schema/evt/evtInfoComplPer/v_S_01_02_00}TS_indSubstPatr'.

Ambiente
 

TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões.

 

Causa 
O erro ocorre quando o indicativo de substituição no cadastro de período de apuração está sem preenchimento, com isso a informação no xml é retornado como 0. De acordo com o Leiaute S -1.2 o mesmo deve ser retornado como 1 ou 2

 



 

Solução
Acesse: Módulo RH | Folha de Pagamento | eSocial | Período de apuração | Acesse o período de apuração desejado e ajuste o campo abaixo. 

 

Após regere o XML S-1280 e integre o mesmo. 

 

Saiba mais
RH - RM - FOP - eSocial - Mapeamento dos eventos eSocial
RH - RM - FOP - eSocial - Como desonerar uma empresa no eSocial

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _