Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro na validação do campo 'nrInsc' no registro 'ideEmpregador': Deve ser um CNPJ válido se {TpInsc} = [1]

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao gerar o XML S-1005 ocorre o erro: erro na validação do campo 'nrInsc' no registro 'ideEmpregador': Deve ser um CNPJ válido se {TpInsc} = [1]

Ambiente
TOTVS  RH - TOTVS RH (Linha RM) - Folha de Pagamento - eSocial - Todas as Versões

Causa
Este incidente ocorre quando a parametrização da Classificação Tributária não está alinhada com o Leiaute do eSocial. O problema surge ao gerar o evento S-1005 para uma pessoa física, caso a Classificação Tributária esteja preenchida com um CNPJ. Isso provoca divergências nas informações e resulta em erro na geração do XML.

A regra exige que o campo seja preenchido com o código apropriado que corresponde ao tipo de inscrição, conforme especificado na Tabela 05. Os códigos válidos são:

  • 1 para CNPJ (Cadastro Nacional da Pessoa Jurídica)
  • 2 para CPF (Cadastro de Pessoas Físicas)

Tabela 05 - Tipos de Inscrição:



Solução

Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse o eSocial | Informações do Empregador;


2. Edite o campo Classificação Tributária;


3. Após gere o XML novamente e envie para o eSocial.

Saiba mais
Para maiores informações acesse: 
Mapeamento dos Eventos eSocial


 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _