Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro na validação do campo 'tpContr': Se codCateg = [103] e dtAdm >= [2024-04-22], deve ser informado [2] Prazo determinado, definido em dias


time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao realizar a geração do XML dos eventos S-2190, S-2200 e S-2206 é apresentado a mensagem abaixo:

 

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões.

Causa
Esse incidente ocorre, pois esta sendo gerado com a tag <tpContr>1<tpContr>;

De acordo com as novas regras da Nota Técnica S-1.2 N° 01/2023 é exigido que o contrato de aprendiz seja por prazo determinado, definido em dias a partir ou igual a data 22/04/2024. Ou seja a tag deverá ser gerado com o tpContr 2. 

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse Administração de Pessoal | Funcionários; 
 

 

 

2. Selecione o Funcionário | Registro | Dados do Contrato; 


 

3. Marque a flag Contrato com Prazo e preencha os campos com as informações, lembre-se que o tipo de contrato é Prazo Determinado, Definido em dias; 

 


4. Após gere novamente o XML e envie para o eSocial; 

 


Saiba mais
Mapeamento dos eventos eSocial

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _