FAQs - Suporte técnico

Processamento das instruções SQL geradas pelos scripts de atualização do banco de dados ou comandos SQL do arquivo ALTER_ORA.SQL relativas à mudança de chaves estrangeiras (FK).

Causa

Processamento das instruções SQL geradas pelos scripts de atualização do banco de dados ou comandos SQL do arquivo ALTER_ORA.SQL relativas à mudança de chaves estrangeiras (FK).

 

Solução

Mudança de chaves estrangeiras são geradas por instruções SQL do tipo “Alter table...drop constraint” e “Alter table...create constraint”.

 

Caso a segunda instrução “Alter table...create constraint” não seja executada, deve-se verificar se a chave primaria da tabela referenciada possui exatamente os mesmos atributos que farão parte da chave estrangeira que esta sendo criada.

Além disso, estes atributos devem possuir o mesmo tipo e tamanho entre as duas tabelas referenciadas.

Caso isto não ocorra, o DBA da empresa deve interceder. O DBA da empresa é o profissional habilitado e capacitado para identificar e solucionar este tipo de ocorrência.

 

De qualquer forma, sugerimos os procedimentos a seguir para orientar o DBA da empresa:

1.) Verificar a chave primaria da tabela referenciada usando as ferramentas de administração do Oracle.

2.) Verificar se os atributos que compõe a chave primaria são exatamente os mesmos da chave estrangeira que esta sendo criada.

3.) Verificar se o tipo e tamanho dos atributos que compõe a chave primaria são exatamente os mesmos da tabela onde a chave estrangeira esta sendo criada.

4.) Caso haja diferenças, o DBA deve ajustá-las.

 

A execução dos procedimentos acima é de responsabilidade do DBA, conforme salientado acima.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados.

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _