FAQs - Suporte técnico

BIA: Conceito Emissão Boletim Agrícola Realizado

Causa

Esclarecer a emissão de dados nas colunas – Dia, Semana, Mês, Safra e principalmente na coluna ‘Safra Anterior’ do Boletim Agrícola (Realizado e Realizado x Meta) quando emitido pelo flag – ‘Data Safra Anterior’  ou quando emitido pelo flag – ‘Dias Correspondentes de Safra’, para melhor entendimento das informações visíveis.

 

Solução

Informações exibidas nas colunas – Dia, Semana, Mês e Safra.

- Coluna DIA: A coluna DIA exibe informações da data informada para emissão do boletim. Por exemplo: O boletim foi emitido no dia 06/03/2009. A coluna DIA exibirá informações desse dia.

 

- Coluna SEMANA: A coluna SEMANA exibe informações do primeiro dia da semana até a data de emissão do boletim. Por exemplo: O boletim foi emitido no dia 06/03/2009, então a coluna SEMANA exibirá informações de 01/03/2009 até 06/03/2009, de acordo com o cadastro do calendário no Pimscs.

 

- Coluna MÊS: A coluna MÊS exibe informações do primeiro dia do mês até o dia em que foi emitido o boletim. No exemplo, o relatório foi emitido no dia 06/03/2009, então na coluna MÊS será exibido dados do dia 01/03 a 06/03/2009.

 

- Coluna SAFRA: Na coluna SAFRA visualiza-se dados do primeiro dia de safra ou primeiro dia de produção (de acordo com a definição da fonte, coluna ‘Ini Prod/Safra’) até o dia de emissão do relatório.

 

Coluna SAFRA ANTERIOR

- Emissão do Boletim Agrícola com o flag – ‘Data Safra Anterior’ marcado:

Quando o Boletim Agrícola é emitido com o flag ‘Data safra anterior’, para gerar os valores da coluna ‘Safra Anterior’, o sistema considera o dia e o mês da data de emissão do boletim e busca o ano da safra anterior. Por exemplo: No print acima a data de emissão do boletim é o dia 06/03/2009. Então o sistema considera o dia 06 do mês 03 e assume o ano anterior - que é 2008, ou seja os valores que serão mostrados na coluna ‘Safra Anterior’ serão da coluna ‘Safra’ gerado no dia 06/03/2008.

 

Obs.: Caso a Geração de Tabelas Configuradas não tenha sido gerada para o dia 06/03/2008 o sistema exibe NULO. Caso a geração de tabelas configuradas tenha sido executada nessa data e não tenha valores para exibir, o sistema mostra 0,00 (zero). Lembrando que todas as informações visualizadas já estão na tabela BOLETIM_AGR_MODxx (onde xx é o número).

 

- Emissão do Boletim Agrícola com o flag – ‘Dias correspondente safra’ marcado:

Quando o Boletim Agrícola é emitido com o flag ‘Dia correspondente safra’, para gerar os valores da coluna ‘Safra Anterior’, o sistema recupera a safra atual e  calcula a quantidade de dias entre o primeiro dia de safra até a data de emissão do boletim. Então recupera a safra anterior juntamente com sua data de inicio de safra  e soma o total de dias calculado anteriormente. Após contagem, o sistema terá uma data base, utilizada para exibição dos dados na coluna ‘Safra Anterior’. No nosso exemplo, a emissão do relatório foi dia 06/03/2009 e o primeiro dia da safra atual é  01/01/2009.  A quantidade de dias entre - 01/01/09 à 06/03/09 são 65. O sistema localiza a safra anterior (safra 2008) e soma 65 dias ao dia 01/01/2008 (primeiro dia da safra anterior). Após contagem, a data base para visualização dos dados na coluna ‘Safra Anterior’ será da geração de dados do dia 05/03/2008.

Obs.: Caso a Geração de Tabelas Configuradas não tenha sido gerada para o dia 05/03/2008 o sistema exibe NULO. Caso a geração de tabelas configuradas tenha sido executada nessa data e não tenha valores para exibir, o sistema mostra 0,00 (zero). Lembrando que todas as informações visualizadas já estão na tabela BOLETIM_AGR_MODxx (onde xx é o número).

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados.

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _