Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGALOJA - Falha na gravação do orçamento pela ExecAuto LOJA701 com problema na validação de estoque (LJ7VEREST)

Tempo aproximado para leitura: 00:01:30 min

Ocorrência

Ao executar a rotina automática (ExecAuto) LOJA701, o sistema não realiza a gravação do orçamento e aponta problemas na validação de estoque vinculados à função LJ7VEREST, especificamente em cenários que utilizam Controle de Rastreabilidade.

Ambiente

Microsiga Protheus - SIGALOJA - A partir da release 12

Causa

Esse incidente ocorre devido à falta de preenchimento ou configuração incorreta das informações obrigatórias de lote e endereço durante a execução da rotina automática para produtos que utilizam o controle de rastreabilidade.

Solução

Para solucionar essa ocorrência e garantir que o ExecAuto grave o orçamento corretamente, realize os seguintes passos de verificação:

  1. Acesse o configurador e valide se o parâmetro MV_RASTRO está devidamente configurado para habilitar o controle de rastreabilidade no ambiente.

  2. No código da sua ExecAuto, certifique-se de que o array de itens está enviando preenchidos os campos obrigatórios de endereçamento e lote do produto:

    • Lote do Produto: Campo LR_LOTECTL

    • Sub Lote do Produto: Campo LR_NLOTE

    • Endereço do Lote: Campo LR_LOCALIZ

  3. Após o ajuste e envio correto desses campos na estrutura da ExecAuto, processe a rotina novamente para que a validação de estoque seja concluída com sucesso e o orçamento seja gravado.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _