Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGALOJA - Reclock nas tabelas FIV e FIW no processamento da venda pelo JOB LJGRVBATCH

Tempo aproximado para leitura: 00:02:30 min

Ocorrência

No módulo SIGALOJA, durante o processamento da venda pelo JOB LJGRVBATCH, ocorre um problema de concorrência informando reclock nas tabelas FIV e/ou FIW.

Ambiente

Microsiga Protheus - SIGALOJA - A partir da release 12

Causa

Em ambientes que possuem diversos jobs para processamento de vendas (LJGRVBATCH), pode ocorrer concorrência na atualização das tabelas FIV e/ou FIW. Isso acontece porque foi criado um processo de atualização de saldos por natureza online, que permite a atualização das tabelas no mesmo momento da venda.

Dessa forma, como a forma de pagamento está amarrada a uma natureza financeira, caso ocorra o processamento de duas vendas que utilizaram a mesma forma de pagamento simultaneamente, ocorre a concorrência e o travamento dos registros.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

  1. Acesse o configurador e verifique a existência do parâmetro MV_FINATFN. Esse parâmetro permite configurar se a atualização de saldos será realizada de forma On-Line ou Off-Line.

  2. Caso o parâmetro não exista, realize a sua criação com as seguintes definições:

    • Nome da var: MV_FINATFN

    • Tipo: Caracter

    • Conteúdo: 2

    • Descrição: "1" = Fluxo Caixa On-Line, "2" = Fluxo Caixa Off-Line

  3. Configure o valor do parâmetro para 2 (Off-Line) para evitar o problema de concorrência (reclock).

  4. Com a rotina configurada como Off-Line, realize o cálculo dos saldos posteriormente através da rotina Recálculo de Saldos por Natureza (FINA800).

    • Caminho: Miscelânea > Processamentos > Rec Saldos P/ Natur.

Observação Importante: Se o parâmetro for configurado ou mantido como On-Line ("1"), além do risco de reclock, pode ocorrer lentidão perceptível no processamento geral das vendas da loja.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _