Tempo aproximado para leitura: 00:01:20 min
Ocorrência
No aplicativo Portal Mobilidade > Geral > Cadastros Gerais > Configurações, ao tentar fazer teste de conexão com o banco de dados, é apresentada a ocorrência Falha ao se conectar ao banco de dados. [Keyword not supported: ‘database’.].
TOTVS Agro – TOTVS Agro – Bioenergia – Portal Mobilidade - MB_PORTAL – Todas as Versões
Causa
Para essa mensagem de falha de conexão, temos que trocar a DLL de conexão ao banco de dados da aplicação no servidor da aplicação do Portal Mobilidade.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Baixe pacote das versões até 2305;
2. Acesse a pasta de download do instalador do portal, extraia o arquivo PortalMobileInstaller;
3. Observe, após a extração, acessar a pasta PortalMobilInstaller/PacotePortalMobile;
4. Abra a pasta Oracle ou SQLServer, de acordo com o banco utilizado da aplicação;
5. Verifique, dentro da pasta copie as DLLs:
- PIMSCol.Framework.dll
- PIMSCol.Objects.dll
6. Acesse agora a pasta de Instalação do Portal, procurando a pasta bin;
7. Substitua as DLLs copiadas anteriormente;
8. Reinicie o Portal no servidor do IIS e faça o teste novamente.
0 Comentários