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Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - WEB - Integração - Pedidos digitados no Neogrid não integram no SFA

 

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Ocorrência

Pedidos ao serem gerados no Neogrid não estão tendo sucesso ao serem integrados com o SFA.

Ambiente
Cross Segmentos - TOTVS CRM Automação e Força de Vendas (SFA) - WEB - Integração - Integração de Pedido Neogrid - Todas as versões

Causa
O código do produto não estava sendo montado corretamente. Com isso, ao tentar enviar o pedido para o SFA, o pedido é rejeitado, uma vez que não é possível uma integração parcial dele.

Ao validar os arquivos de integração de pedidos do Neogrid, podemos encontrar a situação abaixo. Observe:



Veja que o código do produto está sendo montado de uma forma em que está se juntando com o nome do produto, ou seja, ultrapassando o total máximo de caracteres que pode ter e não com o espaço igual aos outros produtos. Isso ocasiona um erro na integração e o envio do pedido ao SFA é abortado para ser corrigida essa informação de produto.

Observe abaixo a mensagem que estamos recebendo de erro (encontrada dentro do log de importação):


 

Como o código do produto não está alimentado corretamente, temos o retorno de que o produto não existe no SFA, uma vez que procura o código do produto como sendo CODIGO+ DESCRIÇÃO do produto em questão.
 
Nossa integração realiza a análise por linhas e colunas procurando o CODIGO, CODIGODEBARRA ou CODIGOADICIONAL.
 
Independente de ser CODIGO, CODIGODEBARRA ou CODIGOADICIONAL, ele sempre localiza esse código entre a coluna 17 e 31 no arquivo enviado pelo Neogrid:
 


 

Observe que existem produtos que estão sendo gerados com itens que ultrapassam o padrão:



Onde temos o 5 antes de COXA SCOXA FGO KG, deveríamos ter um espaço vazio, já que o SFA tenta ler todo esse nome como se fosse o código do produto. Esse demonstra ser o motivo dos produtos não serem integrados.


Solução
Para solucionar essa ocorrência, deve-se entrar em contato com a Neogrid, para que eles verifiquem o motivo de os pedidos que estão sendo criados estarem gerando arquivos de integração com formato incorreto.
Assim que o arquivo de integração for corrigido para os padrões determinados pelo SFA, os pedidos tornarão a ser integrados novamente.

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