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Ocorrência
Pedido retornando como não finalizado após tentativa de integração ao ERP Protheus.
Ao verificar o log de integração, percebemos que temos um retorno parecido com o abaixo:
Ambiente
Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - WEB - Integração - Todas as versões
Causa
Observe que logo abaixo da mensagem de erro, está indicando onde a integração está encontrando problemas, nesse caso no campo SE4 - Condições de Pagamento:
Pode acontecer em diferentes campos e tabelas do Protheus, que se refiram ao pedido que está sendo exportado.
Este incidente ocorre porque existe algum registro bloqueado/inativo no Protheus, e o SFA está tentando integrar movimentações utilizando esse registro, causando um retorno do pedido para o SFA com o status Não Finalizado.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Observe a mensagem informada logo abaixo da mensagem "Este registro está bloqueado para uso";
2. Verifique se o campo indicado na mensagem está inativo ou bloqueado no Protheus;
3. Caso a validação acima seja verdadeira, ou seja, o registro esteja bloqueado, temos duas possibilidades de solução:
- Altere para um cadastro (condição de pagamento, produto, etc) que não esteja bloqueado no Protheus, na tela de pedido do SFA, e salve novamente.
- Ative/Desbloqueie no Protheus, o cadastro que você identificou como bloqueado e salve novamente o pedido no SFA.
4. Após a alteração, podemos aguardar a próxima execução de integração de pedidos, e ele deverá constar corretamente na listagem do Protheus.
Atenção!
Se mesmo com as orientações acima o pedido não seja exportado com o status finalizado contate o suporte técnico pelos canais de atendimentos padrões, para uma análise mais detalhada.
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