Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao digitar o código do produto na inclusão de uma nova solicitação de compra na rotina MATA110 o sistema gera o help A110CONTR.
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Compras - Todas as versões
Causa
Na rotina de solicitação de compras (MATA110), o sistema verifica o campo B1_CONTRAT do cadastro de produto (MATA010) que está sendo digitado. Isso acontece pois esse campo determina se o produto deverá ser utilizado no contrato de parceria. Esse campo pode ter três conteúdos: Sim, Não e Ambos. Quando o conteúdo desse campo for Sim, ele poderá ser utilizado apenas no contrato de parceria e se tentar incluí-lo na solicitação de compra (MATA110) vai gerar o help A110CONTR e quando tentar incluir pelo pedido de compras (MATA121) vai gerar o help A120CONTR.
Solução
Para solucionar essa ocorrência é necessário alterar o campo B1_CONTRAT para Não ou Ambos no Cadastro do Produto (MATA010) ou habilitar o parâmetro MV_PRODCTR.
Saiba Mais:
0 Comentários