Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - array out of bounds ( 0 of 47 ) on A103DTVLD(MATA103X.PRX)

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Ao tentar Incluir ou Alterar Pré-nota de Entrada (MATA140) ou Documento de Entrada (MATA103) apresenta o error.log abaixo, como ajustar o ambiente para emissão dos documentos?

 

array out of bounds ( 0 of 47 ) on A103DTVLD(MATA103X.PRX) 26/02/2024 18:39:19 line : 6232

[TOTVS build: -]
Called from {|| (A103DtVld(M->D1_DTVALID)) .and. (.t.) .and. (A140FldOk())}(MSGETDAD.PRW) 29/02/2024 17:21:47 line : 1275
Called from VALIDGET(MSMGETPR.PRW) 29/02/2024 17:21:47 line : 2069
Called from {|SELF|(VALIDGET(___ODLG,___BVALID,___OGET,,,@LCARGO) .AND. IIF(LNEWGETD .AND. OGLOGETDB:BFIELDOK<>NIL,VALIDGET(___ODLG,OGLOGETDB:BFIELDOK,___OGET,,,@LCARGO), .T. ))}(MSGETDAD.PRW) 29/02/2024 17:21:47 line : 1387
Called from ::MSDIALOG:END
Called from {|| ___ODLG:NLASTKEY := 13, ___ODLG:END(0)}(MSGETDAD.PRW) 29/02/2024 17:21:47 line : 1324
Called from ::MSDIALOG:ACTIVATE
Called from LEDITCOL(MSGETDAD.PRW) 29/02/2024 17:21:47 line : 1387
Called from MSGETDADOS:EDITCELL(MSGETDAD.PRW) 29/02/2024 17:21:47 line : 501
Called from { | NROW, NCOL | SELF:EDITCELL() }(MSGETDAD.PRW) 29/02/2024 17:21:47 line : 404
Called from ::MSDIALOG:ACTIVATE
Called from A140NFISCAL(MATA140.PRW) 23/02/2024 08:01:21 line : 1094
Called from FWFORMBROWSE:EXECUTE(FWFORMBROWSE.PRW) 29/02/2024 17:21:49 line : 1149
Called from {|| OSELF:EXECUTE("A140NFISCAL", 3, 0,"INCLUIR", 3,"","INCLUIR","", 3) }(FWFORMBROWSE.PRW) 29/02/2024 17:21:49 line : 579
Called from ::MSDIALOG:ACTIVATE
Called from FWMBROWSE:ACTIVATE(FWMBROWSE.PRW) 29/02/2024 17:21:47 line : 700
Called from FWMBROWSE(MSLIB.PRW) 29/02/2024 17:21:47 line : 10499
Called from MBROWSE(MSLIB.PRW) 29/02/2024 17:21:47 line : 170
Called from MATA140(MATA140.PRW) 23/02/2024 08:01:21 line : 167
Called from __EXECUTE(APLIB090.PRW) 29/02/2024 17:21:47 line : 735
Called from MDIEXECUTE(APLIB260.PRW) 29/02/2024 17:21:47 line : 924


Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões

 

Causa

Esse incidente ocorre por exemplo, no momento de informar a Data de Validade do Lote do produto.

 

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

 

 - 1 -  Verificar na tabela SD1 se os campos abaixo estão com as opções "Usado" e "Browse" selecionadas. É necessário que esses campos estejam marcados com essa opções.


D1_COD

D1_LOCAL

D1_NUMLOTE

D1_LOTECTL

D1_DTVALID

D1_TIPO_NF

D1_LOTEFOR

 

 - 2 - Caso, mesmo assim persistir a ocorrência, também verificar na tabela SB8 a ordem do campo B8_DFABRIC deverá estar na posição 031 ou 032 não poderá mudar a ordem (legenda vermelha). Veja exemplo abaixo de um ambiente padrão.

 

 

Saiba Mais:

Clique aqui e veja mais artigos sobre MOVIMENTAÇÕES no Estoque

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _