Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Linha Protheus - SIGAFIN - MATA070 - Help: FWFORMCANCEL Problema: Violação de Integridade. Foi encontrada referência de Código (A6_COD) + Nro Agencia (A6_AGENCIA) na tabela SRA - Funcionários

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Help: FWFORMCANCEL
Problema: Violação de Integridade. Foi encontrada referência de Código (A6_COD) + Nro Agencia (A6_AGENCIA) na tabela SRA - Funcionários


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Financeiro - Todas as versões

 

Causa
O HELP em questão é apresentado por uma validação de integridade, via de regra não é possível excluir um cadastro de banco que possui algum tipo de vinculo, seja de movimentações ou associações de tabelas. Nestes casos, não sugerimos a exclusão do mesmo via banco e não é possível excluir via sistema.

Solução

O HELP ocorre, pois na tabela SRA de Funcionários que pertence ao RH, há um relacionamento da tabela SX9.

Veja a mensagem apresentada:
Help: FWFORMCANCEL
Problema: Violação de Integridade. Foi encontrada referência de Código (A6_COD) + Nro Agencia (A6_AGENCIA) na tabela SRA - Funcionários.
Formulário MATA070_SA6

Segue print do relacionamento em questão na tabela SX9.

 

Deve ser validado se o banco que está sendo excluído esta vinculado a algum funcionário nas rotinas do SIGAGPE.
 
 
Uma sugestão seria apenas permanece a conta como bloqueada altera o cadastro e ajusta o campo "Bloqueado".

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _