Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Totvs Backoffice Protheus - SIGACOM - array out of bounds [20] of [19] on MATA116A(MATA116.PRW)


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao acessar a Rotina de Conhecimento de Frete MATA116 e tentar incluir um CTE o sistema gera o errorlog abaixo.

array out of bounds [20] of [19] on MATA116A(MATA116.PRW) 15/02/2024 10:32:39 line : 206

Ambiente
Protheus – Compras – A partir da versão 12.1.2210

Causa
Esse errorlog foi gerado na linha do fonte onde é verificado o Novo Parâmetro da Natureza de Rendimento , muito possivelmente não haja esse parâmetro na sua rotina. O Parâmetro de Natureza de Rendimento é um facilitador que foi desenvolvido para que possamos digitar uma Natureza de Rendimento e ela seja aplicada para todos os itens do CTE, sem que tenhamos que preencher item a item.



Solução

Por gentileza, aplique o pacote abaixo e valide inicialmente em ambiente teste/homologação onde a mesma situação esteja ocorrendo. Observação: Sempre realize backup antes de qualquer atualização.
https://suporte.totvs.com/portal/p/10098/download?e=1134090 para a release 2210
https://tdn.totvs.com/pages/viewpage.action?pageId=811701840

https://tdn.totvs.com/display/PROT/PCOM14007+-+MATA116+-+REINF+-+Facilitador+de+Preenchimento+da+Natureza+de+Rendimento

 

Se mesmo após a aplicação dos pacotes acima o parâmetro não aparecer na tela da rotina, por favor desabilite todos os pontos de entrada seguindo criteriosamente as três formas da documentação abaixo. Isso é necessário pois, por exemplo, o ponto MT116TEL é executado no início da função MATA116A (Digitacao de Conhecimento de Frete) e substitui a tela padrão de parâmetros. O ponto de entrada deve colocar todos os parâmetros no array “aParametros”, e poderá exibi-los, opcionalmente, numa tela customizada . Dessa forma, se o parâmetro da natureza de rendimento não estiver nesse PE não vai aparecer.

MT116TEL - Insere parâmetros ao Array
link: http://tdn.totvs.com.br/pages/releaseview.action?pageId=6085459

 

Saiba Mais:



Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _