Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS - FAT - PROBLEMA AO GRAVAR O DETALHE DA NOTA FISCAL 2 - PROC_GRAVA_DETALHE

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência

No programa de livros fiscais (VGLMFISX), ao tentar realizar o processo de remissão de nota é apresentado a mensagem 'PROBLEMA AO GRAVAR O DETALHE DA NOTA FISCAL 2 - PROC_GRAVA_DETALHE


Ambiente

TOTVS - TOTVS Varejo Supermercados (Linha RMS) - TOTVS Varejo - Todas as versões

Causa

Neste caso é necessário realizar uma análise no arquivo de log do processo de reemissão de nota, 'PC_FIS_NFE.xxx.log' normalmente o mesmo é gerado na pasta DBX caso todos os parâmetros para geração de log estiverem ativos, tais como o parâmetro 30 ORAGERALOG = S e os parâmetros de usuário.

No caso exemplificado o erro estava ocorrendo no insert da tabela VW64_DET_RASTRO



Obs.: Não é regra, mas normalmente estará sendo apresentado nas últimas linhas do log, seguindo neste caso, no insert da tabela VW64_DET_RASTRO foi informado os campos de datas com nulos

v_sql: insert into VW64_DET_RASTRO( ID, CFG_UN , CFG_NUMERO_NF, CFG_SERIE_NF, DET_NITEM, MED_NITEM, MED_NLOTE, MED_QLOTE, MED_DVAL, MED_DFAB, MED_CAGREG) values( 925,50974732000312,59563,'1',1,0,'DRA02205',2, to_date(''), to_date(''),'0')

15-MAR-24 NOTA: 59563 SERIE: 1 ORIGEM : 50974732000312 DATA : 1240307 AGENDA : 132 PRODUTO : 2042223 SEQ : 0 PROBLEMA AO GRAVAR VW64_DET_RASTRO DA NOTA FISCAL 99 - PROC_GRAVA_LOTE ORA-01400: cannot insert NULL into ("RMS"."VW64_DET_RASTRO"."MED_DVAL")
update vw60_det 3

Ao rodar este mesmo select no meu ambiente também foi apresentado o mesmo problema.


veja que os campos de lote e validade e fabricação estão sem informação


Acredito que na geração desta nota não foi passado pelo usuário essas informações, e por isso não estão conseguindo reemitir a mesma.

Ao informar esses campos o select foi executado com sucesso.


Solução

Para solucionar essa ocorrência, realize os seguintes passos:
1. O usuário deve verificar como está o cadastro do produto no programa VABUAITE transação 24;


Corrigindo essa informação via cadastro e ao remitir apresentar o mesmo problema acredito ser necessário proceder com a emissão de uma nova nota.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _