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Ocorrência
Os e-mails de notificação não estão sendo enviados pelo programa html.fiscalCalendar.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Obrigações Fiscais (MOF) - 12.1.31
Causa
Existem alguns motivos mapeados para o programa Calendário Fiscal não realizar envio dos e-mails de notificação. Abaixo, alguns deles e suas soluções.
Solução
1. Ao configurar um novo compromisso, é possível que não tenha sido configurado um responsável válido, fazendo com que não seja enviado nenhum e-mail de notificação.
Para correção dessa situação, basta acessar o programa Manutenção de Usuário - SEC/SEC000AA.R, em Foundation ou Segurança ou Usuários Produto, e verificar se os usuários configurados nos compromissos possuem e-mail cadastrados, e se os e-mails configurados são válidos.
2. Para realizar o envio dos e-mails, é utilizado do Servidor RPW configurado, e o mesmo deve estar configurado de forma que permita o envio.
A configuração dos alertas deve ser feita de acordo com a necessidade, informando quantos dias antes do vencimento do compromisso, além do servidor RPW válido.
Caso os e-mails continuem não sendo enviados, mesmo após realizar as parametrizações acima, enviar os logs do Appserver à nossa equipe de suporte, conforme artigo: Framework - Linha Datasul - TEC - Localização dos arquivos de logs do Appserver Progress para Datasul for THF
Saiba mais
Para maiores informações, consultar nossa documentação técnica sobre o Calendário Fiscal no link: DT Calendário Fiscal
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